HOME 대회개요 신청안내 심사정보 참가신청 신청확인 로그인
Boat
Q&A

Q&A

제목 질문 드립니다.
작성자 이명훈(CS-AI)
질문 PyTorch 1.9와 CUDA 10.2를 이용하려고 합니다. 제가 시도하면 nvcc -V 명령어에는 10.2로 바뀌지만 nvidia-smi 명령어에는 10.0으로 나오고 PyTorch에도 CUDA 사용이 되지 않는데, 혹시 CUDA 버전 변경 방법은 따로 안내받기 어려울까요?
그리고 설치 후에 다시 로그인하면 삭제가 되어 있습니다. 항상 다시 설치해야하나요?

추가로, Slurm 같은 스케줄러는 따로 설치해야하나요?

감사합니다.
답변 워크숍 시간에도 안내드렸습니다만,
CUDA는 10.0버전입니다.
Tensorflow1.14버전기준으로 호환드라이버를 설치해서 CUDA 드라이버는 변경설치가 불가능합니다.
Pytorch를 GPU버전으로 설치하시면서 발생되는 문제일 것으로 추측되는데요. Pytorch를 쓰셔야 한다면 설치된 CUDA드라이버를 사용하거나, 혹은 CPU버전을 사용하는 방법이 있습니다.

jupyterlab에 들어가시면 conda의 기본환경이 base 환경으로 들어가게 됩니다.
base환경에서 pip, conda install 등을 하시면 로그아웃을 하시면 보존되지 않습니다.

pip또는 conda 설치된 패키지가 보존되려면 가상환경을 새로 만드시고, 해당 가상환경에서 설치하시기 바랍니다.

slrum 설치는 따로 필요없습니다.